.NET Development
 
Forums: » Register « |  User CP |  Games |  Calendar |  Members |  FAQs |  Sitemap |  Support | 
 
User Name:
Password:
Remember me
 



Go Back   Dev Articles Community ForumsProgramming.NET Development

Reply
Add This Thread To:
  Del.icio.us   Digg   Google   Spurl   Blink   Furl   Simpy   Y! MyWeb 
Thread Tools Search this Thread Display Modes
 
Unread Dev Articles Community Forums Sponsor:
  #1  
Old September 19th, 2004, 05:21 AM
Jud101 Jud101 is offline
Registered User
Dev Articles Newbie (0 - 499 posts)
 
Join Date: Sep 2004
Posts: 3 Jud101 User rank is Just a Lowly Private (1 - 20 Reputation Level) 
Time spent in forums: < 1 sec
Reputation Power: 0
section registered as allowDefinition='MachineToApplication' beyond application level

ok this is crazy. all the research for this error is not the solution for my problem. I've done the IIS thing and it didn't work. My server structure looks like this:

<root>
project1
Web.Config
................<folder>
.................project2
..................web.config

I have one domain name pointing the the project1 and another domain name pointing to a folder holding project2. The first project gives me no problems but I get that error with the second project. I even went so far as to put all project1 files in project2 and it works in the root but not in the second folder. That pretty much tells me that the error it displays for me isn't correct for this problem. The second project2 seems to be reading the config file, as I make changes to it and it shows me the right changes(usually the form, windows in authentication). but I do get errors with the customErrors. I can't figure this one out. Not really sure what the correct question would be

Maybe I should ask if what I'm doing to upload is correct. I can't seem to find much on this but can I just ftp all the files to a server or is there a special way to do this. Do you deploy a web project (ok that might make me really sound blonde, but the question needed to be asked).
ANYONE UP TO THE CHALLENGE IN SOLVING THIS ONE. If so I'm pretty sure once this is fixed I'll come up with others just like it.

thanks to all, I'll be sitting here day and night looking for a responce lol
Judy


Reply With Quote
  #2  
Old December 7th, 2004, 12:03 PM
NickLucas NickLucas is offline
Registered User
Dev Articles Newbie (0 - 499 posts)
 
Join Date: Feb 2004
Posts: 1 NickLucas User rank is Just a Lowly Private (1 - 20 Reputation Level) 
Time spent in forums: 2 m 19 sec
Reputation Power: 0
I had the same problem. This was because I created a folder manually in the default web site and FTP'd the contents in directly. To clear the problem I went into IIS called up the properties of my new folder and noticed that the application name etc. were dimmed out. All I had to do was click the "Create" button. Voila - the fields were no longer dimmed out and the web service now works.
Please let me know if this solves it for you......

Reply With Quote
  #3  
Old January 10th, 2005, 12:05 PM
Mike10 Mike10 is offline
Registered User
Dev Articles Newbie (0 - 499 posts)
 
Join Date: Jan 2005
Posts: 1 Mike10 User rank is Just a Lowly Private (1 - 20 Reputation Level) 
Time spent in forums: < 1 sec
Reputation Power: 0
Referencing an ASCX UserDontrol in a separate Web Application

I have seen this problem as well, but simply activating the virtual directory as a Web App did not work for me. What I found is that the existence of the web.config file within the separate virtual directory was causing the problem. To explain what I mean, it is probably important to understand how my project is organized:

\\localhost\Portal

\\localhost\applications\app1
\\localhost\applications\app2

Given this configurations of applications published on my web server, I try to "Load" UserControls defined within the application web apps into the Portal web application. This requires a virtual directory defined from the Portal application - like so:

\\localhost\Portal -> \\localhost\applications


I don't understand why, but when I have a web.config file defined within the individual application directories, I receive the error described the the person initiating this thread. Removing the web.config file fixed the problem for me. With that said, it is also important to define the applications virtual directory as a web app, the the last forum post explained.

HTH - if anyone can shed light on the problem with the web.config, please post.

Reply With Quote
  #4  
Old September 20th, 2006, 08:38 PM
oj_arce oj_arce is offline
Registered User
Dev Articles Newbie (0 - 499 posts)
 
Join Date: Sep 2006
Posts: 1 oj_arce User rank is Just a Lowly Private (1 - 20 Reputation Level) 
Time spent in forums: 6 m 11 sec
Reputation Power: 0
Quote:
Originally Posted by NickLucas
I had the same problem. This was because I created a folder manually in the default web site and FTP'd the contents in directly. To clear the problem I went into IIS called up the properties of my new folder and noticed that the application name etc. were dimmed out. All I had to do was click the "Create" button. Voila - the fields were no longer dimmed out and the web service now works.
Please let me know if this solves it for you......




Thanks NickLucas!
... that actually works.

Reply With Quote
  #5  
Old November 2nd, 2006, 10:53 AM
ccody ccody is offline
Registered User
Dev Articles Newbie (0 - 499 posts)
 
Join Date: Nov 2006
Posts: 1 ccody User rank is Just a Lowly Private (1 - 20 Reputation Level) 
Time spent in forums: 14 m 20 sec
Reputation Power: 0
Another possible solution...

I still had the error after having tried all the suggestions above.

However, they lead me to look in a sub-directory within the virtual directory where I found another web.config file for a different (and not active) web application. I moved that sub-directory out of the virtural directory.

Success!

Thanks for all your ideas!

Reply With Quote
  #6  
Old April 3rd, 2007, 02:41 AM
kosmosniks kosmosniks is offline
Registered User
Dev Articles Newbie (0 - 499 posts)
 
Join Date: Apr 2007
Posts: 1 kosmosniks User rank is Just a Lowly Private (1 - 20 Reputation Level) 
Time spent in forums: 7 m 59 sec
Reputation Power: 0
Smile

Hi Everyone,

Just wanted to share, I actually had many web.config files located all over the sub folders because of the nature of the project. However it was the the web.config located in the app_code folder that did the trick!

Thanks Again

Quote:
Originally Posted by ccody
I still had the error after having tried all the suggestions above.

However, they lead me to look in a sub-directory within the virtual directory where I found another web.config file for a different (and not active) web application. I moved that sub-directory out of the virtural directory.

Success!

Thanks for all your ideas!

Reply With Quote
  #7  
Old June 29th, 2007, 04:28 AM
ualino ualino is offline
Registered User
Dev Articles Newbie (0 - 499 posts)
 
Join Date: Jun 2007
Posts: 1 ualino User rank is Just a Lowly Private (1 - 20 Reputation Level) 
Time spent in forums: 18 m 38 sec
Reputation Power: 0
Hi,
my english is bad, i'm sorry.
My problem, instead, is this:

I have 2 appllication app1 e app2 and i would share a session variable. this is no possible and i have put in app2 as subfolder of app1.

code error is here:
Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.

heLP me please!

Reply With Quote
  #8  
Old November 14th, 2007, 09:39 AM
bradwoody bradwoody is offline
Registered User
Dev Articles Newbie (0 - 499 posts)
 
Join Date: Nov 2007
Posts: 1 bradwoody User rank is Just a Lowly Private (1 - 20 Reputation Level) 
Time spent in forums: 7 m 32 sec
Reputation Power: 0
NickLucas - I wasted 2 hours on this yesterday; went home really frustrated.

First thing this morning found your post and Bang-Zoom I'm up and running!

I appreciate people like you who spend the time to help people like me...

Brad

Reply With Quote
  #9  
Old March 13th, 2008, 01:51 PM
jhymes jhymes is offline
Registered User
Dev Articles Newbie (0 - 499 posts)
 
Join Date: Mar 2008
Posts: 1 jhymes User rank is Just a Lowly Private (1 - 20 Reputation Level) 
Time spent in forums: 7 m 33 sec
Reputation Power: 0
Extra webconfig was the issue

This worked for me. Thanks for the post.

Quote:
Originally Posted by Mike10
I have seen this problem as well, but simply activating the virtual directory as a Web App did not work for me. What I found is that the existence of the web.config file within the separate virtual directory was causing the problem. To explain what I mean, it is probably important to understand how my project is organized:

\\localhost\Portal

\\localhost\applications\app1
\\localhost\applications\app2

Given this configurations of applications published on my web server, I try to "Load" UserControls defined within the application web apps into the Portal web application. This requires a virtual directory defined from the Portal application - like so:

\\localhost\Portal -> \\localhost\applications


I don't understand why, but when I have a web.config file defined within the individual application directories, I receive the error described the the person initiating this thread. Removing the web.config file fixed the problem for me. With that said, it is also important to define the applications virtual directory as a web app, the the last forum post explained.

HTH - if anyone can shed light on the problem with the web.config, please post.

Reply With Quote
  #10  
Old December 18th, 2008, 03:23 PM
arunkw arunkw is offline
Registered User
Dev Articles Newbie (0 - 499 posts)
 
Join Date: Dec 2008
Posts: 1 arunkw User rank is Just a Lowly Private (1 - 20 Reputation Level) 
Time spent in forums: 15 m 3 sec
Reputation Power: 0
Help me on my problem

I am getting an error
Server Error in '/' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.

Source Error:

Line 66: </system.codedom>
Line 67: <system.web>
Line 68: <machineKey
Line 69: validationKey="F9D1A2D3E1D3E2F7B3D9F90FF3965ABDAC304902"
Line 70: decryptionKey="F9D1A2D3E1D3E2F7B3D9F90FF3965ABDAC304902F8D923AC"

Source File: E:\inetpub\vhosts\mywebsite.com\httpdocs\website\w eb.config Line: 68

Show Additional Configuration Errors:

It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (E:\inetpub\vhosts\mywebsite.com\httpdocs\website\ web.config line 125)
It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (E:\inetpub\vhosts\mywebsite.com\httpdocs\website\ web.config line 188)
It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (E:\inetpub\vhosts\mywebsite.com\httpdocs\website\ web.config line 196)
Sections must only appear once per config file. See the help topic for exceptions. (E:\inetpub\vhosts\mywebsite.com\httpdocs\website\ web.config line 229)

--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42

I am using Parallels Plesk to Host mywebsite on the remote server, while doing installation of DNN I get this error.

File manager shows (Listed below are few of Important Files and Folders)
  • mywebsite.com/httpdocs (Parallels suggested me that I should upload/FTP my webapplication files on this folder)
  • mywebsite.com/httpdocs/DotNetNuke (Inside this Folder is my webapplication)
  • mywebsite.com/Website
  • mywebsite.com/Website/Install
  • mywebsite.com/Website/Install/install.aspx (I run this in URL)
  • mywebsite.com/web.config
  • mywebsite.com/httpdocs/web.config (This config file has lots of tags and settings provided by DNN)

Folder DotNetNuke is made virtual and 'create application' setting is also 'on' for this Folder
Kindly help me to resolve this issue, I have spent many sleepless nights worrying about this issue.

Thank You.

Reply With Quote
  #11  
Old February 11th, 2009, 10:47 AM
pskaarup pskaarup is offline
Registered User
Dev Articles Newbie (0 - 499 posts)
 
Join Date: Feb 2009
Posts: 1 pskaarup User rank is Just a Lowly Private (1 - 20 Reputation Level) 
Time spent in forums: 3 m
Reputation Power: 0
Thanks

Quote:
Originally Posted by NickLucas
I had the same problem. This was because I created a folder manually in the default web site and FTP'd the contents in directly. To clear the problem I went into IIS called up the properties of my new folder and noticed that the application name etc. were dimmed out. All I had to do was click the "Create" button. Voila - the fields were no longer dimmed out and the web service now works.
Please let me know if this solves it for you......


This solved my problem!!

Reply With Quote
  #12  
Old May 20th, 2009, 09:41 AM
tellter2000 tellter2000 is offline
Registered User
Dev Articles Newbie (0 - 499 posts)
 
Join Date: May 2009
Posts: 1 tellter2000 User rank is Just a Lowly Private (1 - 20 Reputation Level) 
Time spent in forums: 2 m 9 sec
Reputation Power: 0
thank you!

Quote:
Originally Posted by ccody
I still had the error after having tried all the suggestions above.

However, they lead me to look in a sub-directory within the virtual directory where I found another web.config file for a different (and not active) web application. I moved that sub-directory out of the virtural directory.

Success!

Thanks for all your ideas!

This worked for me as well! I had a web.config file in another folder, after I removed it. Everything worked!

Reply With Quote
  #13  
Old July 3rd, 2009, 02:49 PM
sreekumarpr sreekumarpr is offline
Registered User
Dev Articles Newbie (0 - 499 posts)
 
Join Date: Jul 2009
Posts: 1 sreekumarpr User rank is Just a Lowly Private (1 - 20 Reputation Level) 
Time spent in forums: 5 m 35 sec
Reputation Power: 0
i had alsothe same problem , i follwed the tellter2000 's solution ,i had an inactive directory containing a web.config file within my website folder. i removed the folder and -----------------SUCCESS

Reply With Quote
Reply

Viewing: Dev Articles Community ForumsProgramming.NET Development > section registered as allowDefinition='MachineToApplication' beyond application level


Developer Shed Advertisers and Affiliates


Thread Tools  Search this Thread 
Search this Thread:

Advanced Search
Display Modes  Rate This Thread 
Rate This Thread:


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
View Your Warnings | New Posts | Latest News | Latest Threads | Shoutbox
Forum Jump

Forums: » Register « |  User CP |  Games |  Calendar |  Members |  FAQs |  Sitemap |  Support | 
  
 


Powered by: vBulletin Version 3.0.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

© 2003-2014 by Developer Shed. All rights reserved. DS Cluster - Follow our Sitemap